WinDirStat

WinDirStat - Könyvtárstatisztika

Copyright (c) 2003-2005 Bernhard Seifert. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the section entitled "GNU Free Documentation License".

Megtekintheti az összes lemezének felhasználtságát, és segítséget kaphat azok kitakarításához.

Ismerős Önnek a probléma: A merevlemez majdnem tele és Ön nem tudja, hogy mit tegyen, hol találhatók azok a tényleges nagy állományok, amelyek elfoglalják az összes területet. Azok lehet, hogy rejtve vannak több al-al-könyvtárban. Ezek megkeresése a Windows Intézővel fáradságos: Önnek könyvtárakat kell kinyitnia és bezárnia újra meg újra, hogy megtekinthesse a könyvtárak "Tulajdonságait", amelyekben mindig ki kell számolnia az egyes alszerkezetek méretét. Ez így kemény munka a lemezhasználat megállapításához. Ehhez nyújt segítséget a WinDirStat.

A WinDirStat elindításakor a Meghajtó kijelölése párbeszédablak nyílik meg. Kattinson az OK gombra.

Ekkor a WinDirStat beolvassa a teljes könyvtárszerkezetet egyszer (ez néhány pillanatig eltarthat és függ a merevlemez méretétől) és a szerkezetet hasznos nézetekben mutatja be:

WinDirStat
Könyvtárlista Kiterjesztés lista
Térképfa

A nézeteket összekapcsolhatja egymással.

Ön képes a merevlemezét számos módon kitakarítani.

A megjelenítésekben és a Felhasználó által megadott takarítások-ban képes beállítani a saját igényei szerint az alkalmazást.

Rendezés

Jelmagyarázat

Gyakran Ismételt Kérdések

Korlátozások

Eltávolítás

GNU Free Documentation License


What is a Directory Tree?

Mi is van egy könyvtárszerkezetben?

A legtöbb operációs rendszer, így a Microsoft Windows is, az adatokat a merevlemezen hierarchikus rendben tárolja.

Egyrészt ott vannak a fájlok, amelyek tényleges adattartalommal és mérettel rendelkeznek. Minden fájl rendelkezik egy névvel. A Microsoft Windows alatt a "fájlnév kiterjesztése" információkat ad a fájl típusáról. Az ".exe" kiterjesztés például, egy programfájlt jelez. A ".doc" kiterjesztés egy WinWord dokumentumra utal, a ".jpg" kiterjesztés egy képállomány, és így tovább. De nevetségesen, a Microsoft Windows Intéző a fájlnevek kiterjesztéseit alapértelmezésben elrejti. Ön módosíthatja ezt a jellemzőt a Windows Intéző beállítások menüjében.

Másrészt ott vannak a könyvtárak. A Windows Intéző és a WinDirStat, a könyvtárakat sárga mappákkal szimbolizálja. A könyvtárak is rendelkeznek névvel, de normál esetben kiterjesztés nélkül szerepelnek. A könyvtárak csak fájlokat és más egyéb könyvtárakat ("alkönyvtárak") tartalmaznak. Annak köszönhetően, hogy a könyvtárak tartalmazhatnak alkönyvtárakat és azok újra tartalmazhatnak alkönyvtárakat, ez eredményezi a lemez hierarchikus szerkezetét.

A "hierarchikus szerkezet" helyett egyszerűen mondjuk csak, hogy faszerkezet. Egy fa is hierarchikusan épül fel: A törzs elágazik ágakba, az ágak újabb ágakba és azok al-ágakba ágaznak el, míg eljutunk a legalsó szintig a levelekig. A fájlrendszer un. gyökérkönyvtár rendszert alkot, innen ágaznak el az alkönyvtárak és a fájlok.

Ezért hívjuk a számítógép fájlrendszerét egyszerűen "faszerkezetnek".

A valóságos faszerkezettől eltérően, a lemezen a törzsön és az elágazásokon is lehetnek al elemek. És a legvalóságosabb faszerkezettől eltérően: a fájlok terjedelmes tulajdonságokkal rendelkeznek (mérettel, amelyet megabájt-al, vagy gigabájt-al jelölünk), addíg a könyvtárak elhanyagolható mérettel rendelkeznek. Egyébként elvonatkoztathatunk a faszerkezet képétől: a gyökér lehet felül és a levelek (fájlok) alul.

Ha Ön megnéz egy elágazást a fában és azt beleszúrja a földbe, akkor abból egy kisebb fa lesz: Minden elágazás folytatódhat egy al-elágazásban és állományokban, ez a faszerkezet az al-faszerkezet.

A családfa hasonlatot szintén gyakran használjuk: A könyvtár alkönyvtárai és fájljai a gyermekek. És az alkönyvtárakat, vagy fájlokat tartalmazó könyvtár a szülő könyvtár. A gyökérkönyvtár a legelső elődje a könyvtárszerkezetben lévő összes elemnek.

Az útvonalban "C:\documents\letters\draft\loveletter.doc" jelölésre kerül a merevlemez C:, a gyökérkönyvtár "C:\" a "documents" könyvtár, alatta a "letters" alkönyvtár, ez alatt a "draft" alkönyvtár és maga a "loveletter.doc" fájl. Tehát az útvonal pontosan ábrázolja az elágazásokat az utólsó állományig.


Directory List

Könyvtár lista

A könyvtárlista hasonlít a Windows Explorer faszerkezetére, azzal a különbséggel, hogy a könyvtárak és a fájlok méret szerint csökkenő sorrendben jelennek meg. Felül láthatja azokat a könyvtárakat és a fájlokat, amelyek a legnagyobb területet használják. Amikor kinyit egy könyvtárat, az alkönyvtárak is a fentiek alapján méretük szerint jelennek meg.

Oszlopok

  • Név. Ebben az oszlopban jelenik meg a könyvtárak és fájlok neve és azok faszerkezete.
  • Méret. Fájlok esetén a fájl mérete bájtban jelenik meg. Könyvtárak esetén ez a méret tartalmazza minden alkönyvtár és fájl méretét.
  • Részfa százalék. Ebben az oszlopban láthatja, hogy az adott állomány és annak elemei mekkora helyet foglalnak el az adathordozón. Ez az információ összehasonlító jellegű csak az egy szinten és mindig kapcsolatban lévő szülő elemeken belül érvényes.
    [A vizsgálat alatt, ebben az oszlopban megjeleníthet egy "pacman" figurát, vagy a beolvasott állományok számát.]
  • Százalék. A "Részfa százalék" oszlopban megjelenített információk mutatása százalékban.
    [A vizsgálat alatt, ebben az oszlopban opcionálisan megjelenítheti az eltelt időt.]
  • Fájlok. Fájlok száma a részfában.
  • Alkönyvtárak. Alkönyvtárak száma a részfában.
  • Elemek. Elemek száma a részfában. A "Fájlok" és "Alkönyvtárak" összege.
  • Utóljára módosítva. A részfa módosításának utólsó dátuma.
  • Attribútumok. Fájl/mappa attribútumok. R = írásvédett, H = rejtett, S = rendszer, A = archív, C = tömörített, E = titkosított.

Műveletek

A "Név" oszlopban Ön képes az egere kattintásával kinyitni és összezárni a könyvtárakat. Kattintson a négyzetekben lévő + és - jelre, úgy mint a Windows Explorer-ben. Ha egy névre kattint, azzal kijelöli az elemet. Ezután könnyedén navigálhat a faszerkezetben a nyíl billentyűkkel.

A térképfában a kijelölt elem, mindig kiemelt keretben jelenik meg.

Ha kijelöl egy fájlt, a kiterjesztés listában automatikusan megjelenik, annak a típusa.

A rendezést beállíthatja az oszlop fejlécére történő egérkattintással.


Extension List

Kiterjesztés lista

A kiterjesztések listája tartalmaz minden olyan típust (fájlnév kiterjesztést) amely előfordul a könyvtárszerkezetben. A "Bájt" oszlopban láthatja, hogy az adott fájltípus mekkora helyet foglal összesen. Alapértelmezésben a kiterjesztés lista, ebben az oszlopban csökkenő sorrendben kerül rendezésre. Így legfelül vannak azok a fájltípusok, amelyek a legtöbb helyet foglalják el a merevlemezén.

12 szín került hozzárendelésre, a 12 leggyakoribb fájltípushoz. A maradék szürke színű. A térképfában az állományok is ezekkel a színekkel jelennek meg.

Oszlopok

  • Kiterjesztés. Ikon és fájlnév kiterjesztések.
  • Szín. Színek, amelyek a fájltípusok megjelenítésére kerültek felhasználásra a térképfában.
  • Leírás. A fájltípus leírása. A leírás megjelenítése hasonlít a Windows Explorer-hez.
  • Bájt. A kötet faszerkezetében lévő azonos fájltípusok összes mérete.
  • % Bájt. Az adott fájltípus százalékos aránya a könyvtárszerkezetben.
  • Fájl. Az adott fájltípus száma a könyvtárszerkezetben.

Műveletek

Kattintson egy kiterjesztésre: A térképfában kiemelésre kerül az összes ilyen típusú fájl.


Treemap

Térképfa

A térképfa megjeleníti a teljes könyvtár faszerkezetet és tartalmát.

Itt egy fájl egy színes téglalappal kerül jelölésre, a területe arányos a fájl méretével.

A téglalapok úgy vannak elrendezve, hogy azok újra téglalapokkal vannak kibélelve, melyek tartalmazzák az összes fájlt és alkönyvtárat. Így a területek arányosak az alszerkezetek méreteivel.

A téglalapok színezése jelzi a fájl típusát, melyet megtekinthet a kiterjesztések listájában.

A kipárnázás árnyékolása, kiegészítő megjelenítése a könyvtárszerkezetnek.

Műveletek

Ön könnyedén megtekintheti a nagy téglalapokat, így ezen keresztül a nagy állományokat, még ha azok mélyen is vannak elrejtve egy alkönyvtárban a könyvtárszerkezeten belül. Kattintson egy elemre: a könyvtár listában megnyílik a fájl útvonala és elolvashatja a helyét és az atrribútumait, és - feltéve ha szeretné - végrehajthat egy takarítási műveletet, pl. törölheti a fájlt.

Navigálhat a könyvtár listában: a megfelelő kijelöléshez a keret más színnel kerül kiemelésre. Így megláthatja az arányokat: Milyen nagy például a C:\windows könyvtár, összevetve a C:\program files könyvtárral?

A környezeti menü opciói a "Szülő kijelölése" és a "Gyermek újrajelölése" segítik a navigációt.

Nagyítás. A "Nagyítás" opcióval felnagyíthatja a térképfát, úgy hogy az alszerkezetek is teljes méretben jelennek meg. A gyökéren belüli könyvtár lista és alszerkezetek kék kerettel jelennek meg. A "Kicsinyítés" opcióval Ön egy lépéssel visszaléphet és a szülő elemet láthatja újra.


Coupling of the Views

Megjelenítések kapcsolódása

Ez egy valóban erős pont a WinDirStat-ban, hogy a faszerkezet nézete, a Könyvtár lista, a Kiterjesztések listája és a Térképfa, hogyan kapcsolódik egymáshoz.

Könyvtár lista -> Térképfa

Amikor Ön kijelöl egy elemet (könyvtárat, vagy fájlt) a könyvtárlistában, a térképfában szintén kiemelt kerettel jelenik meg ez az elem. Ezzel a speciális tulajdonsággal Ön áttekintheti a könyvtárak, vagy fájlok méretét.

Térképfa -> Könyvtár lista

Amikor Ön rákattint a térképfára az egérrel, mindig egy állományt talál (színezett téglalap). Ezután, amikor kinyitja a könyvtár listát (ha szükséges) megláthatja a kijelölt állomány kapcsolódásait. Így Ön képes, pl. egy kattintással egy nagy téglalapon, megtekinteni az állomány útvonalát és atrribútumait a könyvtárlistában.

Mivel ezek kapcsolatban vannak egymással, a könyvtár lista és a térképfa mindig szinkronban van egymással.

Könyvtár lista + Térképfa -> Kiterjesztés lista

Amikor kijelöl egy fájlt a könyvtárlistában (vagy a térképfában), a fájl típusa megjelenik a kiterjesztés listában. A kijelölt kiterjesztést görgetheti is ebben a nézetben. Így Ön megtekintheti a leírását és a statisztikáját az ilyen típusú fájloknak.

Kiterjesztés lista -> Térképfa

Amikor kijelöl egy fájltípust a kiterjesztések listájában, a térképfában minden ilyen típusú fájl kijelölésre kerül.


Select Drives Dialog

Meghajtó kijelölése párbeszédablak

Itt Ön eldöntheti, hogy melyik meghajtó statisztikáját szeretné megtekinteni.

Ön kiválaszthat, egy vagy több meghajtót, vagy választhat egy könyvtárat a listából.

A listában megjelenik, minden rendelkezésre álló meghajtó (merevlemez, behelyezett floppy, vagy CD-k, és a hálózati meghajtók).

Oszlopok

  • Név. A meghajtó neve és betűjele.
  • Teljes. A meghajtó kapacitása.
  • Szabad. Szabad terület nagysága a meghajtón.
  • Foglalt/Teljes Használt terület aránya a kapacitás függvényében.
  • Foglalt/Teljes Ugyanezen információk százalékban.

Műveletek

Az ablakban lévő "rádógombok" használata.

  • Minden helyi meghajtó. Ez az alapértelmezett. Minden helyi meghajtó vizsgálata a hálózati meghajtók nélkül. A létrehozott SUBST meghajtók szintén kizárva (csak NT és magasabb).
  • Egyéni meghajtók. Itt megadhatja konkrétan, hogy melyik meghajtót akarja kijelölni.
  • A mappa. Itt Ön kijelölhet egy mappát, vagy egy UNC útvonalat.
Kattintson az OK gombra a vizsgálat elkezdéséhez.

A kijelölések megmaradnak, így amikor Ön legközelebb megnyitja a párbeszédablakot, az Ön által beállítottak lesznek az alapértelmezettek.


Clenaups

Kitakarítás

A kijelölt elemhez, többféle takarítási műveletet alkalmazhat. A takarításhoz hozzáférhet a fő menün, az eszköztáron és gyorsbillentyűkön keresztül.

Kijelölt frissítése

Lehet, hogy néhány elem törlésre, vagy módosításra került a WinDirStat-on kívül. A "Frissítés" végrehajtásával a WinDirStat újraolvassa az elemet, hogy a képernyő összhangban legyen újra a merevlemez állapotával.

Útvonal másolása

Kijelölt elem útvonalának másolása a vágólapra.

Megnyitás

A kijelölt fájl megnyitása. Figyelem: abban az esetben, ha ez egy futtatható fájl (.exe), a program gondolkodás nélkül elindul.

Intéző most

A Windows Intéző elindítása, hogy megtekinthesse a kijelölt elemet.

Parancssor most

DOS parancssor megnyitása a kijelölt könyvtárban.

Törlés (a Lomtárba)

A kijelölt elem áthelyezése a Lomtárba. Ekkor az elem és a lomtár könyvtár is frissítésre kerül.

Törlés (nem állítható vissza)

A kijelölt elem visszafordíthatatlan törlése. Ekkor az elem frissítésre kerül. Kérem, csak olyan fájlokat és könyvtárakat töröljön, amelyekről tudja, hogy sem a rendszere, sem más alkalmazása nem igényli többet!

Tulajdonságok

A kijelölt fájl 'Tulajdonságok' ablakának megnyitása.

Levél küldése a tulajdonosnak

Szöveges jelentés készítése a kijelölt könyvtárról, amelyet e-mailben elküldhet a tulajdonosnak. Ez lehet hálózati meghajtó is, amelyet több személy is használ. A jelentés pontosan soronként tartalmazza a képernyőn kijelölt elem alatt lévő könyvtárak listáját, ugyanúgy "kibontott állapotban" és ugyanolyan rendezési sorrendben.

Felhasználó által meghatározott takarítások

További takarítási műveleteket adhat meg igényei szerint adja meg a saját takarításait.


User Defined Cleanups

Felhasználó által megadott takarítások

Haladó felhasználók részére.

Ön megadhat 10 egyéni takarítási műveletet. Ezek a takarítások a parancssorban kerülnek megadásra.

Válasszon ki egy bejegyzést a listából és "engedélyezze" azt. Válasszon egy nevet, amely a menüben fog megjelenni.

Állítsa össze a parancssort. Használja az "MSDOS parancssort" (Windows 9x, command.com), vagy a "Parancssor"-t (NT, cmd.exe) ahol segítséget kaphat a rendelkezésre álló parancsokhoz, és tesztelheti azokat.

Példák

  • dir /b > dir.txt
    Fájlnevek kilistázása a dir.txt szövegfájlba.
  • del *.bak
    Összes *.bak fájl törlése az aktuális könyvtárban.
  • del /s *.bak *.tmp
    Rekurzívan törli az összes *.bak és *.tmp fájlt.
  • windirstat.exe "%p"
    A WinDirStat második példányának meghívása, amely tartalmazza a kijelölt könyvtár útvonalát (egy ÚTVONALAT (PATH) a windirstat.exe-hez be kell állítania).

Példák (NT és magasabb)

  • echo %n & pause
    Az aktuális könyvtár nevének megjelenítése.
  • cd & pause
    Az aktuális útvonal megjelenítése és várakozás egy billentyű leütésre.
  • cd .. && myzip "%n"
    Kijelölt könyvtár tömörítése (feltételezve, hogy a tömörítő eszköze a myzip).

A kifejezésekben használhatja a %p, %n, %sp, %sn helyettesítő karaktereket. Ne felejtse el, hogy azokat idézőjelek között kell használnia.

Assembly parancssorban

Feltételezve ha megadta a parancssort

xyz
. amikor a WinDirStat megpróbálja elkezdeni a következő folyamatot:
%COMSPEC% /c xyz

További lehetőségek

Megadhatja, hogy milyen elemtípusok legyenek törölve. Legyen óvatos az UNC útvonalakkal: a chdir parancs nem működik az UNC útvonalaknál!

Megadhatja, hogy melyik takarítás kerüljön végrehajtásra rekurzívan minden alkönyvtárban (első mélység).

Más opciókat is alkalmazhat a takarításhoz.


Configuration

Beállítás

Általános

Keresztfájlrendszer csatolások (csak NT és újabb). NTFS alatti köteteket kapcsolhat be a könyvtárakba. A WinDirStat alapértelmezés szerint leállítja az ilyen csatolási pontok beolvasását, így csak egy fájlrendszer használatát mutatja meg. Itt Ön módosíthatja ezt a tulajdonságot. (A felismert UNC meghajtókat nem csatolja be.)

Következő csatolási pontok (kivéve a kötet csatolási pontokat) (csak NT és újabb). NTFS alatt lévő mappákat, képes összekapcsolni más csatolási pontok alatt használt mappákkal. (Ehhez Önnek szüksége lesz egy harmadik fél eszközésre, pl. az awxlink-re, letöltheti innen: http://www.arniworld.de/, csatolási pont létrehozásához.) Alapértelmezés szerint a WinDirStat leállítja az ilyen csatolási pontok beolvasását. Itt Ön megváltoztathatja ezt a jellemzőt.

Lista stílus. Ezzel az opcióval sorokat és rácsozást alkalmazhat a WinDirStat listáiban.

Nyelv. Beépített kiegészítő nyelv az Angol, a legördülő listában találja azokat a nyelveket, amelyekhez a kapcsolódó wdsrxxxx.dll létezik. A módosítások érvényesítéséhez újra indítania a WinDirStat-ot.

Könyvtár lista

Két opció, amellyel kezelheti, hogy az 'Alszerkezet százalék' és 'Százalék' oszlopok kötül melyik jelenjen meg a vizsgálat alatt a képernyőn. A színekkel az alszerkezet százalékaránya kerül bemutatásra.

Térképfa

Paraméterek a négyszögletes stílus, a párnázás árnyékolása, a rácsvonalak és a kijelölés színeinek beállításához.

Kitakarítás

Itt beállíthatja a Felhasználói takarítások jellemzőit.

Jelentés

Az adminisztrátorok itt testreszabhatják az e-mail jelentés tulajdonságait.


Sorting

Rendezés

A WinDirStat-ban, minden lista a tetszése szerint rendezhető. Az aktuális rendezési elvet a < és > szimbólum jelzi az oszlop fejlécében. a < érték növekvő sorrendet, a > érték csökkenő sorrendet jelöl.

Ön a kívánt rendezési sorrendet az oszlop fejlécére történő kattintással állíthatja be.

Jelenleg kettő oszlopban van berajzolva a rendezési jel. Először döntse el, hogy melyikre akar kattintani, és másodikként - ha az oszlopban lévő elemek megfelelőek - válassza ki a rendezési sorrendet.

Jegyezze meg a rendezés figyelembe veszi a könyvtárlista faszerkezetét: a rendezés lehetséges csak egy szinten belül is.

Megjegyzés

Az oszlopok szélessége és elrendezése 'húzd és ejtsd' módszerrel alakítható. Ha az oszlopok szélességét és elrendezését a kívánalmai szerint megváltoztatta, a program a következő indulásakor automatikusan helyreállítja az eredeti beállításokat.


Legend

Jelmagyarázat

<Fájl>

Általában a könyvtárlista minden egyes könyvtárában található egy látszólagos alkönyvtár <Fájl>. Oda, minden a könyvtárban lévő szokásos fájl összerakásra kerül. Azaz minden olyan fájl, amely közvetlen leszármazottja a könyvtárnak és nem alkönyvtárakban helyezkedik el. Ez hasznos lehet, amikor a könyvtár listát takarítja. Ezzel az elemmel megtekintheti, hogy mekkora területet használ összesen a könyvtárban (nem az alkönyvtárakban).

A <Fájl> elem elhagyható, ha csak egy fájl van a könyvtárban, vagy ha nincsenek alkönyvtárak.

<Szabad terület>

Ha aktiválja a "Szabad terület kijelzése" lehetőséget a Beállítások menüben, minden meghajtón megjelenik a <Szabad terület> elem. Az elem mérete megegyezik a meghajtón rendelkezésre álló szabad terület méretével. Ez az elem a térképfában sötétszürke színű. A <Szabad terület> elem híven tükrözi a teljes használt lemezterület és a szabad lemezterület arányát. Ez az információ megfelel a Windows Intéző tulajdonságok párbeszédablakában megjelenő értékeknek.

<Ismeretlen>

Ha aktiválja a Beállítások menüben az "Ismeretlen megjelenítése" opciót, minden meghajtón lesz egy <Ismeretlen> elem. Ez egy lényeges dolog a következők szerint. Egyrészt a WinDirStat tudja, hogy mekkora a lemez teljes kapacitása és a szabad terület nagysága. (Ezek a megjelenő értékek megyegyeznek a Windows Intéző lemeztulajdonságok párbeszédabalakában látható értékekkel.) Másrészt a WinDirStat képes meghatározni az összes elem és fájl méretét. Nos az <Ismeretlen> ebben különbözik: A teljes kapacitásból kivonva a szabad terület nagysága, ebből kivonva a meghatározott összeg. A maradék nagyobb mint nulla. Előfordulhat a meghajtón olyan terület (pl. "System Volume Information"), amely olvasás és hozzéférés ellen védve van. Ennek a méretét a WinDirStat nem képes meghatározni és beleszámolni a használt terület méretébe. A térképfában az <Ismeretlen> jelzésű elem világos sárgával színezve.

< (az oszlopok fejlécében)

a jelző a lista rendezettségére utal az oszlop fejlécében - növekvő sorrend.

> (az oszlopok fejlécében)

a jelző a lista rendezettségére utal az oszlop fejlécében - csökkenő sorrend.


Frequently Asked Questions

Gyakran Ismételt Kérdések

A térképfa összefüggésben áll-e merevlemez szektor kiosztásával?

Nem. A térképfa megjelenítése egyáltalán nincs kapcsolatban a merevlemez szektoraival. Általában a nyagobb állományok szétszórva találhatók a merevlemezen. A térképfa másképp kezeli a megjelenítésüket, minden egyes állomány egy téglalappal kerül megjelenítésre.

Indít-e újabb szálakat a WinDirStat az olvasási folyamatokhoz?

Nem. A WinDirStat is - elkülönülő önálló szálon fut.

Mit jelent a <Fájl> elem?

Nézze meg a Jelmagyarázatot.

Mit jelent a > szimbólum az oszlopfeliratok előtt?

A > és < szimbólum az oszlop fejlécekben az aktuális rendezési sorrendet jelenti.

Az én XP WinDirStat-om GB-nál nagyobb <Ismeretlen> állományt jelez, ez hiba?

Egyáltalán nem. Az XP gyakran létrehoz egy meglehetősen nagy 'Rendszer visszaállító pontot' itt: C:\System Volume Information, de ehhez nem engedi a hozzáférést.

Mihez kell a wdsr0407.dll fájl?

Ez a fájl tartalmazza a WinDirStat német nyelvű fordítását. A 0407 a "Német - Németország" nyelvi azonosítója. Ha ez a fájl hiányzik, akkor a WinDirStat csak a beépített Angol nyelven érhető el.

KB-ban és MB-ban a méret információ túl kicsinek látszik.

A WinDirStat a számítástechnikában elfogadott átváltást alkalmazza, tehát a "kiló" nem 1000-et jelent, hanem
            1024-et. Így tehát:
1 KB = 1024 Bájt
1 MB = 1024 KB = 1,048,576 Bájt
1 GB = 1024 MB = 1,048,576 KB = 1,073,741,824 Bájt.


Limits

Korlátozások

Vizsgálatra felhasználható folyamatos időtartam | 2^32 ms (= 49 nap)
Egy könyvtárban lévő al-elemek maximális száma | 2^31 (= 2,147,483,648)
Maximális fájlméret, faszerkezet mérete | 2^63 (= 8,388,608 TB)
Maximális elemszám | 2^63
Maximális egyidejű beolvasási folyamat száma | 2^63


Deinstallation

Eltávolítás

  • Törölje a C:\program files\windirstat könyvtárat
  • Törölje a WinDirStat parancsikonját
  • Szakértőknek: Törölje a HKCU\Software\seifert\windirstat bejegyzést.


GNU Free Documentation License

Version 1.2, November 2002

Copyright (C) 2000,2001,2002  Free Software Foundation, Inc.
59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed.

0. PREAMBLE

The purpose of this License is to make a manual, textbook, or other functional and useful document "free" in the sense of freedom: to assure everyone the effective freedom to copy and redistribute it, with or without modifying it, either commercially or noncommercially. Secondarily, this License preserves for the author and publisher a way to get credit for their work, while not being considered responsible for modifications made by others.

This License is a kind of "copyleft", which means that derivative works of the document must themselves be free in the same sense. It complements the GNU General Public License, which is a copyleft license designed for free software.

We have designed this License in order to use it for manuals for free software, because free software needs free documentation: a free program should come with manuals providing the same freedoms that the software does. But this License is not limited to software manuals; it can be used for any textual work, regardless of subject matter or whether it is published as a printed book. We recommend this License principally for works whose purpose is instruction or reference.

1. APPLICABILITY AND DEFINITIONS

This License applies to any manual or other work, in any medium, that contains a notice placed by the copyright holder saying it can be distributed under the terms of this License. Such a notice grants a world-wide, royalty-free license, unlimited in duration, to use that work under the conditions stated herein. The "Document", below, refers to any such manual or work. Any member of the public is a licensee, and is addressed as "you". You accept the license if you copy, modify or distribute the work in a way requiring permission under copyright law.

A "Modified Version" of the Document means any work containing the Document or a portion of it, either copied verbatim, or with modifications and/or translated into another language.

A "Secondary Section" is a named appendix or a front-matter section of the Document that deals exclusively with the relationship of the publishers or authors of the Document to the Document's overall subject (or to related matters) and contains nothing that could fall directly within that overall subject. (Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any mathematics.) The relationship could be a matter of historical connection with the subject or with related matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The "Invariant Sections" are certain Secondary Sections whose titles are designated, as being those of Invariant Sections, in the notice that says that the Document is released under this License. If a section does not fit the above definition of Secondary then it is not allowed to be designated as Invariant. The Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections then there are none.

The "Cover Texts" are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover Texts, in the notice that says that the Document is released under this License. A Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.

A "Transparent" copy of the Document means a machine-readable copy, represented in a format whose specification is available to the general public, that is suitable for revising the document straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or (for drawings) some widely available drawing editor, and that is suitable for input to text formatters or for automatic translation to a variety of formats suitable for input to text formatters. A copy made in an otherwise Transparent file format whose markup, or absence of markup, has been arranged to thwart or discourage subsequent modification by readers is not Transparent. An image format is not Transparent if used for any substantial amount of text. A copy that is not "Transparent" is called "Opaque".

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input format, LaTeX input format, SGML or XML using a publicly available DTD, and standard-conforming simple HTML, PostScript or PDF designed for human modification. Examples of transparent image formats include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited only by proprietary word processors, SGML or XML for which the DTD and/or processing tools are not generally available, and the machine-generated HTML, PostScript or PDF produced by some word processors for output purposes only.

The "Title Page" means, for a printed book, the title page itself, plus such following pages as are needed to hold, legibly, the material this License requires to appear in the title page. For works in formats which do not have any title page as such, "Title Page" means the text near the most prominent appearance of the work's title, preceding the beginning of the body of the text.

A section "Entitled XYZ" means a named subunit of the Document whose title either is precisely XYZ or contains XYZ in parentheses following text that translates XYZ in another language. (Here XYZ stands for a specific section name mentioned below, such as "Acknowledgements", "Dedications", "Endorsements", or "History".) To "Preserve the Title" of such a section when you modify the Document means that it remains a section "Entitled XYZ" according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that this License applies to the Document. These Warranty Disclaimers are considered to be included by reference in this License, but only as regards disclaiming warranties: any other implication that these Warranty Disclaimers may have is void and has no effect on the meaning of this License.

2. VERBATIM COPYING

You may copy and distribute the Document in any medium, either commercially or noncommercially, provided that this License, the copyright notices, and the license notice saying this License applies to the Document are reproduced in all copies, and that you add no other conditions whatsoever to those of this License. You may not use technical measures to obstruct or control the reading or further copying of the copies you make or distribute. However, you may accept compensation in exchange for copies. If you distribute a large enough number of copies you must also follow the conditions in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.

3. COPYING IN QUANTITY

If you publish printed copies (or copies in media that commonly have printed covers) of the Document, numbering more than 100, and the Document's license notice requires Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you as the publisher of these copies. The front cover must present the full title with all words of the title equally prominent and visible. You may add other material on the covers in addition. Copying with changes limited to the covers, as long as they preserve the title of the Document and satisfy these conditions, can be treated as verbatim copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should put the first ones listed (as many as fit reasonably) on the actual cover, and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either include a machine-readable Transparent copy along with each Opaque copy, or state in or with each Opaque copy a computer-network location from which the general network-using public has access to download using public-standard network protocols a complete Transparent copy of the Document, free of added material. If you use the latter option, you must take reasonably prudent steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will remain thus accessible at the stated location until at least one year after the last time you distribute an Opaque copy (directly or through your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing any large number of copies, to give them a chance to provide you with an updated version of the Document.

4. MODIFICATIONS

You may copy and distribute a Modified Version of the Document under the conditions of sections 2 and 3 above, provided that you release the Modified Version under precisely this License, with the Modified Version filling the role of the Document, thus licensing distribution and modification of the Modified Version to whoever possesses a copy of it. In addition, you must do these things in the Modified Version:

  • A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and from those of previous versions (which should, if there were any, be listed in the History section of the Document). You may use the same title as a previous version if the original publisher of that version gives permission.
  • B. List on the Title Page, as authors, one or more persons or entities responsible for authorship of the modifications in the Modified Version, together with at least five of the principal authors of the Document (all of its principal authors, if it has fewer than five), unless they release you from this requirement.
  • C. State on the Title page the name of the publisher of the Modified Version, as the publisher.
  • D. Preserve all the copyright notices of the Document.
  • E. Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.
  • F. Include, immediately after the copyright notices, a license notice giving the public permission to use the Modified Version under the terms of this License, in the form shown in the Addendum below.
  • G. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given in the Document's license notice.
  • H. Include an unaltered copy of this License.
  • I. Preserve the section Entitled "History", Preserve its Title, and add to it an item stating at least the title, year, new authors, and publisher of the Modified Version as given on the Title Page. If there is no section Entitled "History" in the Document, create one stating the title, year, authors, and publisher of the Document as given on its Title Page, then add an item describing the Modified Version as stated in the previous sentence.
  • J. Preserve the network location, if any, given in the Document for public access to a Transparent copy of the Document, and likewise the network locations given in the Document for previous versions it was based on. These may be placed in the "History" section. You may omit a network location for a work that was published at least four years before the Document itself, or if the original publisher of the version it refers to gives permission.
  • K. For any section Entitled "Acknowledgements" or "Dedications", Preserve the Title of the section, and preserve in the section all the substance and tone of each of the contributor acknowledgements and/or dedications given therein.
  • L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles. Section numbers or the equivalent are not considered part of the section titles.
  • M. Delete any section Entitled "Endorsements". Such a section may not be included in the Modified Version.
  • N. Do not retitle any existing section to be Entitled "Endorsements" or to conflict in title with any Invariant Section.
  • O. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary Sections and contain no material copied from the Document, you may at your option designate some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the Modified Version's license notice. These titles must be distinct from any other section titles.

You may add a section Entitled "Endorsements", provided it contains nothing but endorsements of your Modified Version by various parties--for example, statements of peer review or that the text has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as a Back-Cover Text, to the end of the list of Cover Texts in the Modified Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements made by) any one entity. If the Document already includes a cover text for the same cover, previously added by you or by arrangement made by the same entity you are acting on behalf of, you may not add another; but you may replace the old one, on explicit permission from the previous publisher that added the old one.

The author(s) and publisher(s) of the Document do not by this License give permission to use their names for publicity for or to assert or imply endorsement of any Modified Version.

5. COMBINING DOCUMENTS

You may combine the Document with other documents released under this License, under the terms defined in section 4 above for modified versions, provided that you include in the combination all of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant Sections of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections may be replaced with a single copy. If there are multiple Invariant Sections with the same name but different contents, make the title of each such section unique by adding at the end of it, in parentheses, the name of the original author or publisher of that section if known, or else a unique number. Make the same adjustment to the section titles in the list of Invariant Sections in the license notice of the combined work.

In the combination, you must combine any sections Entitled "History" in the various original documents, forming one section Entitled "History"; likewise combine any sections Entitled "Acknowledgements", and any sections Entitled "Dedications". You must delete all sections Entitled "Endorsements."

6. COLLECTIONS OF DOCUMENTS

You may make a collection consisting of the Document and other documents released under this License, and replace the individual copies of this License in the various documents with a single copy that is included in the collection, provided that you follow the rules of this License for verbatim copying of each of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under this License, provided you insert a copy of this License into the extracted document, and follow this License in all other respects regarding verbatim copying of that document.

7. AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and independent documents or works, in or on a volume of a storage or distribution medium, is called an "aggregate" if the copyright resulting from the compilation is not used to limit the legal rights of the compilation's users beyond what the individual works permit. When the Document is included in an aggregate, this License does not apply to the other works in the aggregate which are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the Document is less than one half of the entire aggregate, the Document's Cover Texts may be placed on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if the Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole aggregate.

8. TRANSLATION

Translation is considered a kind of modification, so you may distribute translations of the Document under the terms of section 4. Replacing Invariant Sections with translations requires special permission from their copyright holders, but you may include translations of some or all Invariant Sections in addition to the original versions of these Invariant Sections. You may include a translation of this License, and all the license notices in the Document, and any Warranty Disclaimers, provided that you also include the original English version of this License and the original versions of those notices and disclaimers. In case of a disagreement between the translation and the original version of this License or a notice or disclaimer, the original version will prevail.

If a section in the Document is Entitled "Acknowledgements", "Dedications", or "History", the requirement (section 4) to Preserve its Title (section 1) will typically require changing the actual title.

9. TERMINATION

You may not copy, modify, sublicense, or distribute the Document except as expressly provided for under this License. Any other attempt to copy, modify, sublicense or distribute the Document is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

10. FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that a particular numbered version of this License "or any later version" applies to it, you have the option of following the terms and conditions either of that specified version or of any later version that has been published (not as a draft) by the Free Software Foundation. If the Document does not specify a version number of this License, you may choose any version ever published (not as a draft) by the Free Software Foundation.

How to use this License for your documents

To use this License in a document you have written, include a copy of the License in the document and put the following copyright and license notices just after the title page:

Copyright (c)  YEAR  YOUR NAME.
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.2
or any later version published by the Free Software Foundation;
with no Invariant Sections, no Front-Cover Texts, and no Back-Cover
Texts.  A copy of the license is included in the section entitled "GNU
Free Documentation License".

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the "with...Texts." line with this:

with the Invariant Sections being LIST THEIR TITLES, with the
Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.

If you have Invariant Sections without Cover Texts, or some other combination of the three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these examples in parallel under your choice of free software license, such as the GNU General Public License, to permit their use in free software.