WinDirStat

WinDirStat - Statystyki Katalogu

Copyright (c) 2003-2005 Bernhard Seifert. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the section entitled "GNU Free Documentation License".

Pokazuje, gdzie zniknęła wolna przestrzeń Twojego dysku i pomoga ją odzyskać.

Znasz ten problem: Dysk twardy jest prawie zapełniony, a Ty nie wiesz, gdzie są położone największe pliki, które zajmują wolną przestrzeń. Mogą być wszędzie, mogą być ukryte, znajdować się w pod-pod-katalogach. Znajdowanie ich za pomocą Eksploratora Windows jest męczące. Musisz bez końca rozwijać i zwijać katalogi, pokazywać Właściwości aby sprawdzić jaką przestrzeń zajmuje tylko bieżący katalog. W ten sposób bardzo trudno wyobrazić sobie obraz przestrzeni dysku twardego. To jest właśnie zadanie dla programu WinDirStat!

Po uruchomieniu program WinDirStat otwiera Okno wyboru dysków. Naciśnij przycisk OK.

WinDirStat czyta całe drzewo katalogów (co może zająć kilka minut, w zależności od pojemności dysku twardego) i reprezentuje je z użyciem interfejsu graficznego w postaci widoków:

WinDirStat
Lista Katalogów Lista rozszerzeń plików
Mapa drzewa

Wszystkie widoki są ze sobą w relacji.

Możesz wyczyścić dysk twardy używając kilkunastu Porządkowań.

Widoki i Porządkowania mogą być konfigurowane wg osobistych preferencji każego użytkownika.

Sortowanie

Legenda

Często zadawane pytania

Ograniczenia

Deinstalacja

Licencja GNU Free Documentation


Co to jest Drzewo Katalogów?

W większości systemów komputerowych, również w Microsoft Windows, dane na twardym dysku są zorganizowane hierarchicznie.

Z jednej strony są to pliki, posiadające określony rozmiar i zawierające dane. Każdy plik ma nazwę. W Microsoft Windows "rozszerzenie pliku" informuje o jego typie. Na przykład rozszerzenie "*.exe", oznacza program wykonywalny, rozszerzenie "*.doc" oznacza dokument Word, "*.jpg" jest obrazem, itd. Niestety Eksplorator Windows domyślnie ukrywa rozszerzenia plików. Można zmienić to zachowanie korzystając z menu opcje Eksploratora.

Z drugiej strony są to katalogi. WinDirStat, podobnie jak Eksplorator Windows pokazuje katalogi w postaci ikonek symbolizujących żółte teczki. Katalogi także mają nazwę, ale normalnie nie posiadają rozszerzenia. Katalogi służą jedynie do przechowywania plików i innych katalogów ("podkatalogów"). Zgodnie z założeniem, że katalogi mogą przechowywać inne podkatalogi, a te znowu mogą przechowywać podkatalogi, powstaje hierarchiczna struktura na dysku.

Zamiast "hierarchiczna struktura" możemy po prostu powiedzieć struktura drzewa. Drzewo też jest zbudowane hierarchicznie. Mamy gałęzie, które przechodzą w podgałęzie, a te znowu w podgałęzie, aż do końca, gdzie mamy liście. W systemie plików też mamy gałęzie (katalogi), liście (pliki) oraz korzeń drzewa (dysk twardy).

Dlatego właśnie system plików komputera możemy określić mianem "drzewa katalogów".

Inaczej niż w rzeczywistości, na dysku pień i gałęzie mogą mieć liście. Pliki - liście, inaczej niż w rzeczywistości mogą mieć większą objętość (mierzoną w megabajtach lub gigabajtach), niż niektóre gałęzie (katalogi). Mimo wszystko możemy sobie wyobrazić drzewo obrócone, do góry korzeniem, a listkami na dół.

Jeżeli odłamałeś gałąź drzewa i położyłeś ją na ziemi, to ona sama stała się małym drzewem (tak przynajmniej można sobie ją wyobrazić): Każda gałąź, razem z jej podgałęziami i liśćmi, jest sama drzewem, dokładniej poddrzewem.

W stosunku do systemu plików możemy użyć metafory Rodzina drzew. Podkatalogi i pliki określonego katalogu są nazywane jego dziećmi. Natomiast katalog zawierający te elementy możemy nazwać ich rodzicem. Katalog główny (korzeń, lub z angielskiego 'root') jest najwcześniejszym (najstarszym) przodkiem wszystkich elementów w drzewie katalogów.

Ścieżka "C:\documents\letters\draft\loveletter.doc" określa dysk twardy c:, w głównym katalogu "C:\" znajduje się katalog "documents", dalej podkatalog "letters", jeszcze jeden podkatalog "draft" i na końcu mamy plik "loveletter.doc". Zatem ścieżka w precyzyjny sposób określa drogę, jaką należy przebyć od głównego katalogu (korzenia), do pliku (liścia).


Lista katalogów

Lista katalogów pokazuje zawartość dysku w postaci drzewa (jak Eksplorator Windows), z tą różnicą, że katalogi i pliki są posortowane wg rozmiarów w porządku malejącym. Na samej górze znajdują się katalogi i pliki, które zajmują nawięcej przestrzeni na dysku twardym. Kiedy rozwiniesz katalog, jego zawartość jest posortowana w taki sam sposób, itd...

Kolumny

  • Nazwa. Ta kolumna pokazuje nazwy plików i katalogów, oraz ich drzewiastą strukturę.
  • Rozmiar. Dla plików, jest to rozmiar pliku w bajtach. Dla katalogów, jest to rozmiar poddrzewa, który jest sumą rozmiarów wszystkich jego podkatalogów oraz plików.
  • Poddrzewo procentowo. Kolumna pokazuje, jaka jest wielkość poddrzewa w stosunku do wielkości jego elementów. Informacja ta jest porównywalna jedynie dla jednego poziomu i zawsze odnosi się do rozwiniętego elementu nadrzędnego
    [Podczas skanowania kolumna ta pokazuje animację pacman oraz liczbę procesów czytających dla danego poddrzewa.]
  • Procentowo. Umieszczona jest tutaj ta sama informacja, jak w kolumnie "Poddrzewo procentowo", ale w procentach.
    [Podczas skanowania kolumna ta może opcjonalnie pokazywać czas zużyty na skanowanie danego poddrzewa.]
  • Pliki. Liczba plików w poddrzewie.
  • Podkatalogi. Liczba podkatalogów w poddrzewie.
  • Elementy. Liczba elementów w poddrzewie. Suma ilości "Plików" i "Podkatalogów".
  • Ostatnia modyfikacja. Data ostatniej modyfikacji w poddrzewie.
  • Atrybuty. Atrybuty pliku/katalogu. R = tylko do odczytu, H = ukryty, S = systemowy, A = archiwalny, C = skompresowany, E = zaszyfrowany.

Operacje

W kolumnie "Nazwa" możesz rozwijać i zwijać katalogi klikając na małe kwadraciki ze znakiem + lub -, tak jak w Eksploratorze Windows. Kliknięcie na nazwę wybiera dany element. Następnie możesz nawigować po drzewie, używając klawiszy strzałek.

Mapa drzewa zawsze oznacza wybrane elementy za pomocą kolorowej ramki.

Jeżeli wybierzesz plik, lista rozszerzeń plików pokazuje jego typ.

Sortowanie może być zadane, przez kliknięcie na nagłówku kolumny.


Lista rozszerzeń plików

Lista rozszerzeń plików zawiera wszystkie typy rozszerzeń występujące w drzewie katalogowym. Dla każdego typu kolumna "Bajtów" pokazuje sumę rozmiaru plików o danym rozszerzeniu. Domyślnie, lista rozszerzeń jest sortowana malejąco wg tej kolumny. Tak więc na samej górze znajdują te typy plików, które zajmują najwięcej przestrzeni na twardym dysku.

Dwanaście kolorów jest przypisanych do tych dwunastu typów plików, które zajmują najwięcej przestrzeni na dysku. Reszta jest szara. Pliki te są reprezentowane na mapie drzewa za pomocą tych właśnie kolorów.

Kolumny

  • Rozszerzenie. Ikona i nazwa rozszerzenia.
  • Kolor. Kolor, jaki jest używany do przedstawienia plików tego typu na mapie drzewa.
  • Opis. Opis typów plików. Opis ten jest tożsamy z opisem jaki można zobaczyć w Eksploratorze Windows.
  • Bajtów. Całkowita objętość plików o tym typie rozszerzenia w drzewie katalogowym. Suma rozmiarów wszystkich plików o danym typie.
  • % Bajtów. Ta sama informacja jako procent zajętości całego drzewa katalogowego.
  • Plików. Liczba plików o danym rozszerzeniu w całym drzewie katalogowym.

Operacje

Kliknięcie na rozszerzeniu: Mapa drzewa podświetla wszystkie pliki danego typu.


Mapa drzewa

Mapa drzewa pokazuje całą zawartość drzewa katalogów w prosty i zrozumiały sposób.

Każdy plik jest reprezentowany przez kolorowy prostokąt, o powierzchni proporcjonalnej do rozmiaru tego pliku.

Prostokąty są ułożone w taki sposób, że katalogi też będące prostokątami, zawierają wszystkie swoje pliki i podkatalogi. Oznacza to, że ich powierzchnia jest proporcjonalna do rozmiaru ich podrzew katalogowych.

Kolor prostokąta określa typ pliku, tak jak to pokazano na liście rozszerzeń plików.

Cieniowanie dodatkowo podkreśla strukturę katalogów.

Operacje

Bez większego trudu możesz zobaczyć duże prostokąty, oznaczające duże pliki, nawet jeżeli są one ukryte gdzieś głęboko w strukturze drzewa. Kliknij na nie: lista katalogów pokaże ścieżkę do wybranego pliku. Możesz teraz odczytać jego położenie, atrybuty. Jeżeli chcesz możesz także uruchomić porządkowanie tego elementu, np. usunięcie pliku.

Nawigacja po liście katalogów: wybrany element jest wyróżniony za pomocą kolorowej ramki. W ten sposób uzyskujesz wrażenie proporcji, np. Jak duży jest C:\windows w porównaniu do C:\program files?

Opcje menu kontekstowego "Skocz poziom wyżej" oraz "Skocz poziom niżej" ułatwiają nawigację po mapie drzewa.

Zmiana rozmiaru. Opcja "Powiększ" powoduje, że wybrane podrzewo jest wyświetlane w pełnym rozmiarze. W takim przypadku, wierzchołek wybranego poddrzewa jest oznaczony niebieską ramką na liście katalogów. Wybranie opcji "Pomniejsz" powoduje cofnięcie się poziom wyżej, do elementu nadrzędnego względem bieżącego elementu.


Relacje między widokami

Wspaniałą funkcjonalnością programu WinDirStat jest złączenie trzech widoków: Listy katalogów, Listy rozszerzeń plików oraz Mapy drzewa, za pomocą relacji.

Lista katalogów -> Mapa drzewa

Kiedy wybierasz pozycję (katalog lub plik) na liście katalogów, mapa drzewa także wskazuje ten element, zaznaczając go kolorową ramką. W szczególności możesz zobaczyć rozmiar katalogów.

Mapa drzewa -> Lista katalogów

Kiedy klikniesz element na mapie drzewa, zostaje on zazaczony kolorową ramką. Po tej operacji lista katalogów jest rozwijana (jeżeli to konieczne) i wybierany jest wskazany plik. Możesz więc, przez kliknięcie na dużym prostokącie, zobaczyć ścieżkę do pliku, jego nazwę i atrybuty.

Zatem użycie relacji powoduje, że elementy wybrane na liście katalogów i na mapie drzewa są zawsze takie same.

Lista katalogów + Mapa drzewa -> Lista rozszerzeń plików

Kiedy wybierasz plik na liście katalogów (lub na mapie drzewa), lista rozszerzeń pokazuje typ pliku (rozszerzenie). Rozszerzenie jest wybierane i pokazywane na liście, która jest tak przesuwana, aby było ono widoczne w oknie. Możesz zatem zobaczyć opis i statystyki dla tego typu pliku.

Lista rozszerzeń -> Mapa drzewa

Kiedy wybierasz określony typ pliku na liście rozszerzeń, mapa drzewa oznacza wszystkie pliki o wybranym typie.


Okno wyboru dysków

Możesz tutaj zdecydować, które dyski włączyć do statystyki.

Możesz wybrać katalog, pojedynczy dysk, lub wszystkie dyski z listy.

Lista pokazuje wszystkie istniejące dyski (dyski twarde, dyskietki w stacjach dysków, płyty CD w czytnikach oraz dyski sieciowe).

Kolumny

  • Nazwa. Nazwa i litera danego dysku.
  • Pojemność. Pojemność dysku.
  • Wolne. Wolna przestrzeń na dysku.
  • Używane/Pojemność Stosunek zajętej przestrzeni do pojemności dysku.
  • Używane/Pojemność Stosunek zajętej przestrzeni do pojemności dysku w procentach.

Operacje

Okno ma trzy przyciski do wyboru dysków.

  • Wszystkie dyski lokalne. Wybrane domyślnie. Będą skanowane wszystkie dyski lokalne, tj. bez dysków sieciowych oraz bez dysków utworzonych za pomocą komendy SUBST (NT lub wyższe).
  • Określone dyski. Możesz bezpośrednio wybrać, które dyski będą skanowane.
  • Katalog. Możesz wybrać katalog, lub ścieżkę UNC.
Kliknij na przycisk OK, aby rozpocząć skanowanie.

Twój wybór jest zapamiętywany, co oznacza, że gdy ponownie otworzysz to okno, wybrane poprzednio ustawienia będą od razu dostępne.


Porządkowania

Istnieje możliwość użycia kilkunastu akcji oczyszczania, które mogą być uruchamiane dla wybranego elementu. Porządkowania są dostępne z menu głównego, z paska narzędzi oraz za pomocą skrótów klawiszy.

Odśwież zaznaczone

Może się zdarzyć, że plik lub katalog zostanie usunięty w czasie działania programu WinDirStat. Polecenie "Odśwież" powoduje ponowne odczytanie zawartości dysku.

Kopiuj ścieżkę

Kopiuje ścieżkę wybranego elementu do schowka.

Otwórz

Otwiera/uruchamia wybrany plik, w zależności od jego typu.

Eksploruj

Uruchamia Eksploratora Windows dla wybranego elementu.

Wiersz polecenia

Uruchamia Linię Poleceń w wybranym katalogu.

Usuń (do kosza)

Usuwa wybrany element do kosza. Po tej operacji zawartość katalogu z elementem usuniętym, oraz zawartość kosza są odświeżane.

Usuń (trwale)

Usuwa wybrany element trwale (bez możliwości odzyskania). Usuwaj tylko te elementy, o których jesteś pewien, że nie będziesz ich nigdy więcej potrzebował!

Właściwości

Otwiera okno "Właściwości" dla wybranego elementu.

Wyślij pocztę do użytkownika

Generuje tekstowy raport o wybranym katalogu, który może być wysłany pocztą elektroniczną do jego właściciela. Ta właściwość została stworzona z myślą o dyskach sieciowych, które mogą być używane przez wielu użytkowników. Raport zawiera linie z listy katalogów, wyświetlane poniżej wybranego elementu, używając tego samego formatowania i sortowania.

Porządkowania użytkownika

Oprócz standardowo zdefiniowanych porządkowań, możesz dowolnie stworzyć swoje własne porządkowania.


Porządkowania użytkownika

Tej właściwości powinni używać użytkownicy zaawansowani.

Możesz zdefiniować do 10 akcji porządkowania dysku. Porządkowania są określone przez polecenia uruchamiane z linii poleceń.

Wybierz określoną pozycję z listy i włącz ją zaznaczając opcję 'Aktywne'. Podaj nazwę, która będzie wyświetlana w menu.

Wpisz polecenia w oknie 'Wiersz polecenia'. Użyj "Trybu MS-DOS" (Windows 9x, command.com) lub "Wiersza polecenia" (NT, cmd.exe), aby uzyskać pomoc na temat dostępnych poleceń i aby przetestować ich działanie.

Przykłady

  • dir /b > dir.txt
    Eksportuje nazwy plików do pliku dir.txt.
  • del *.bak
    Usuwa wszystkie pliki z rozszerzeniem *.bak w bieżącym katalogu.
  • del /s *.bak *.tmp
    Usuwa pliki z rozszerzeniem *.bak oraz *.tmp z bieżącego katalogu i wszystkich jego podkatalogów.
  • windirstat.exe "%p"
    Uruchamia drugą instancję programu WinDirStat, ze ścieżką do wybranego katalogu (w zmiennej PATH musi być ścieżka do programu WinDirStat).

Przykłady (NT i wyższe)

  • echo %n & pause
    Wyświetla nazwę bieżącego katalogu.
  • cd & pause
    Wyświetla bieżącą ścieżkę i czeka na naciśnięcie dowolnego klawisza.
  • cd .. && myzip "%n"
    Kompresuje wybrany katalog (z użyciem hipotetycznego programu myzip).

Znaczenie symboli zastępczych %p, %n, %sp, %sn jest omówione w oknie dialogowym. Nie zapomnij umieścić ich w cudzysłowie, jeżeli zachodzi taka potrzeba.

Wykonywanie linii poleceń

Przypuśćmy, że użytkownik wpisał polecenie

xyz
WinDirStat próbuje uruchomić następujący proces:
%COMSPEC% /c xyz

Więcej opcji

Określenie, dla jakich typów pozycji (pliki, katalogi) działa porządkowanie. Ostrożnie z używaniem ścieżek UNC: wiersz polecenia nie zmienia ścieżki (chdir) na ścieżkę UNC!

Określenie, czy porządkowanie ma przebiegać wgłąb (rekurencyjnie) dla wszystkich podkatalogów (pierwsze najgłębsze).

Znaczenie innych opcji nie powinno sprawiać problemów.


Konfiguracja

Ogólne

Ograniczenia krzyżowych systemów plików (NT lub wyższy). W systemie NTFS można montować katalogi. Domyślnie WinDirStat przestaje skanować po napotkaniu takiego punktu montowania, tzn. pokazuje użycie tylko w jednym systemie plików. Można tutaj zmienić domyślne ustawienia programu. (Punkty montowania nie są rozpoznawane dla dysków UNC.)

Przejdź przez punkty krzyżowe (oprócz punktów montowania dysków) (NT lub wyższy). W systemie NTFS katalog docelowy może być "przeszczepiany" do innego katalogu przez użycie punktów krzyżowych (z angielskiego "node points") (Do tworzenia takich punktów potrzeba oddzielnego oprogramowania, np. awxlink, który można załadować z http://www.arniworld.de/.) Domyślnie WinDirStat zatrzymuje skanowanie katalogu po napotkaniu takiego punktu. Tutaj można zmienić to zachowanie.

Styl listy. Opcje mają zastosowanie do wszystkich list w programie WinDirStat.

Język. Oprócz wbudowanego języka angielskiego, za pomocą tej opcji można zmienić język na inny, spośród oferowanych przez program WinDirStat (patrz dostępność biblioteki wdsrxxxx.dll). Zmiana języka jest widoczna, po restarcie programu.

Lista katalogów

Dwie opcje kontrolujące kolumny 'Poddrzewo procentowo' i 'Procentowo' wyświetlane w czasie skanowania. Można wybrać kolory wyświetlane dla procentowej prezentacji poddrzewa.

Mapa drzewa

Opcje do zarządzania wyglądem mapy drzewa; cieniowaniem, liniami siatki, kolorem wybranego prostokąta.

Porządkowanie

Możesz tutaj zdefiniować swoje własne porządkowania.

Raport

Administratorzy mogą określić wygląd wysyłanego raportu.


Sortowanie

Wszystkie listy w programie WinDirStat mogą być sortowane wg potrzeb. Bieżące sortowanie jest oznaczane symbolem < lub > w nagłówku kolumny. < oznacza sortowanie rosnąco, a > sortowanie malejąco.

Możesz ustawić pożądane sortowanie, klikając na nagłówku wybranej kolumny.

W rzeczywistości dwie kolumny są odświeżane, po przesortowaniu. Pierwsza, to ta, która została kliknięta przez użytkownika w celu posortowania. Druga - jeżeli elementy w sortowanej właśnie kolumnie są takie same - to ta, która była posortowana poprzednio.

Sortowanie listy katalogów uwzględnia strukturę drzewa: sortowane są elementy znajdujące się na tym samym poziomie.

Uwagi

Szerokość kolumn oraz ich ułożenie może być regulowane za pomocą technologii przeciągnij i upuść. Ułożenie kolumn i ich szerokość są zapamiętywane. Oznacza to, że po ponownym uruchomieniu programu przywracane są ostatnie ustawienia użytkownika.


Legenda

<Pliki>

Każdy katalog na liście katalogów ma pseudo podkatalog <Pliki>. Znajdują się w nim wszystkie uporządkowane pliki, tj. wszystkie pliki, znajdujące się bezpośrednio w tym katalogu (ale nie w podkatalogach tego katalogu). Ma to tą zaletę, że struktura listy katalogów jest prostsza, a statystyki bardziej przejrzyste. W ten sposób można łatwo sprawdzić, jaką przestrzeń na dysku zajmują pliki tylko w tym katalogu.

Pseudo katalog <Pliki> nie jest wyświetlany w przypadku, gdy katalog zawiera tylko jeden plik, lub jeżeli nie ma on podkatalogów.

<Wolna przestrzeń>

Jeżeli włączyłeś opcję "Pokaż wolną przestrzeń" z menu Opcje, każdy dysk będzie miał dodatkową pozycję <Wolna przestrzeń>. Rozmiar tej pozycji jest sumą wolnego miejsca na bieżącej partycji. Na mapie drzewa pozycja ta jest oznaczona ciemno-szarym kolorem. Za jej pomocą użytkownik może sprawdzić jaki jest stosunek przestrzeni wolnej do przestrzeni zajętej. Informacja o wielkości wolnej przestrzeni na dysku koresponduje z informacją, którą otrzymujemy używając Eksploratora Windows.

<Nieznany>

Jeżeli włączyłeś opcję "Pokaż element nieznany" z menu Opcje, każdy dysk będzie miał dodatkową pozycję <Nieznany>. Działanie tej opcji jest następujące. Z jednej strony, WinDirStat zna całkowitą pojemność dysku i całkowitą ilość wolnej przesrzeni na tym dysku. (Są to min. wartości wyświetlane przez Eksploratora Windows dla określonego dysku.) Z drugiej strony, WinDirStat zlicza wielkości wszystkich plików i je dodaje. Zatem element <Nieznany> jest różnicą między: Całkowita pojemność - wolna przestrzeń - wyliczona wielkość wszystkich plików. Ta wielkość może być większa od zera z kilku powodów. Mogą to być katalogi (np. "System Volume Information"), którego nie można czytać (ustawiony odpowiedni atrybut), zatem jego rozmiar nie będzie zsumowany przez WinDirStat. Na Mapie drzewa elementy takie są oznaczone kolorem jasno-żółtym.

< (w nagłówku kolumny)

Oznacza, że lista jest sortowana w porządku rosnącym.

> (w nagłówku kolumny)

Oznacza, że lista jest sortowana w porządku malejącym.


Często zadawane pytania

Czy mapa drzewa odzwierciedla położenie sektorów na twardym dysku?

Nie. Mapa drzewa nie przedstawia położenia sektorów na dysku. Ogólnie, duże pliki są pofragmentowane na dysku twardym, natomiast mapa drzewa pokazuje każdy plik jako jeden prostokąt.

Czy WinDirStat uruchamia wątki w procesie odczytu?

Nie. WinDirStat jest jedno-wątkowy, z wyjątkiem okna o programie, które jest uruchamiane we własnym wątku, oraz okna wyboru dysku/ów. Wszystkie zadania są wykonywane w czasie bezczynności systemu (OnIdle()).

Co oznacza pozycja <Pliki>?

Patrz Legenda.

Co oznacza symbol > przed nazwą kolumny?

Symbole > i < w nazwach kolumn oznaczają bieżące sortowanie.

W moim Windows XP WinDirStat pokazuje więcej niż 1 GB dla pozycji <Nieznany>, czy coś jest nie tak?

Wszystko jest w porządku. Windows XP dość często tworzy 'Punkty przywracania systemu' o dużej objętości, w katalogu C:\System Volume Information i jednocześnie zabrania dostępu do nich.

Do czego służy plik wdsr0407.dll?

Plik ten zawiera Niemieckie tłumaczenie programu WinDirStat. 0407 jest identyfikatorem dla 'Niemcy - Niemiecki'. Brak tego pliku oznacza, że program WinDirStat jest dostępny jedynie we wbudowanym języku Angielskim.

Rozmiary podawane w KB i MB wydają się być trochę za małe.

WinDirStat do obliczania rozmiarów używa konwencji 1024,
        w której:
1 KB = 1024 Bajtów
1 MB = 1024 KB = 1,048,576 Bajtów
1 GB = 1024 MB = 1,048,576 KB = 1,073,741,824 Bajtów.


Ograniczenia

Czas skanowania | 2^32 ms (= 49 dni)
Liczba bezpośrednich potomków katalogu | 2^31 (= 2,147,483,648)
Rozmiar pliku, rozmiar drzewa | 2^63 (= 8,388,608 TB)
Łączna liczba pozycji | 2^63
Liczba niezależnych procesów odczytu | 2^63


Deinstalacja

  • Usuń katalog C:\program files\windirstat
  • Usuń skróty dla programu WinDirStat
  • Dla użytkowników zaawansowanych: Usuń HKCU\Software\seifert\windirstat.


Licencja GNU (GNU Free Documentation License)

Version 1.2, November 2002

Copyright (C) 2000,2001,2002  Free Software Foundation, Inc.
59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed.

0. PREAMBLE

The purpose of this License is to make a manual, textbook, or other functional and useful document "free" in the sense of freedom: to assure everyone the effective freedom to copy and redistribute it, with or without modifying it, either commercially or noncommercially. Secondarily, this License preserves for the author and publisher a way to get credit for their work, while not being considered responsible for modifications made by others.

This License is a kind of "copyleft", which means that derivative works of the document must themselves be free in the same sense. It complements the GNU General Public License, which is a copyleft license designed for free software.

We have designed this License in order to use it for manuals for free software, because free software needs free documentation: a free program should come with manuals providing the same freedoms that the software does. But this License is not limited to software manuals; it can be used for any textual work, regardless of subject matter or whether it is published as a printed book. We recommend this License principally for works whose purpose is instruction or reference.

1. APPLICABILITY AND DEFINITIONS

This License applies to any manual or other work, in any medium, that contains a notice placed by the copyright holder saying it can be distributed under the terms of this License. Such a notice grants a world-wide, royalty-free license, unlimited in duration, to use that work under the conditions stated herein. The "Document", below, refers to any such manual or work. Any member of the public is a licensee, and is addressed as "you". You accept the license if you copy, modify or distribute the work in a way requiring permission under copyright law.

A "Modified Version" of the Document means any work containing the Document or a portion of it, either copied verbatim, or with modifications and/or translated into another language.

A "Secondary Section" is a named appendix or a front-matter section of the Document that deals exclusively with the relationship of the publishers or authors of the Document to the Document's overall subject (or to related matters) and contains nothing that could fall directly within that overall subject. (Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any mathematics.) The relationship could be a matter of historical connection with the subject or with related matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The "Invariant Sections" are certain Secondary Sections whose titles are designated, as being those of Invariant Sections, in the notice that says that the Document is released under this License. If a section does not fit the above definition of Secondary then it is not allowed to be designated as Invariant. The Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections then there are none.

The "Cover Texts" are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover Texts, in the notice that says that the Document is released under this License. A Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.

A "Transparent" copy of the Document means a machine-readable copy, represented in a format whose specification is available to the general public, that is suitable for revising the document straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or (for drawings) some widely available drawing editor, and that is suitable for input to text formatters or for automatic translation to a variety of formats suitable for input to text formatters. A copy made in an otherwise Transparent file format whose markup, or absence of markup, has been arranged to thwart or discourage subsequent modification by readers is not Transparent. An image format is not Transparent if used for any substantial amount of text. A copy that is not "Transparent" is called "Opaque".

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input format, LaTeX input format, SGML or XML using a publicly available DTD, and standard-conforming simple HTML, PostScript or PDF designed for human modification. Examples of transparent image formats include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited only by proprietary word processors, SGML or XML for which the DTD and/or processing tools are not generally available, and the machine-generated HTML, PostScript or PDF produced by some word processors for output purposes only.

The "Title Page" means, for a printed book, the title page itself, plus such following pages as are needed to hold, legibly, the material this License requires to appear in the title page. For works in formats which do not have any title page as such, "Title Page" means the text near the most prominent appearance of the work's title, preceding the beginning of the body of the text.

A section "Entitled XYZ" means a named subunit of the Document whose title either is precisely XYZ or contains XYZ in parentheses following text that translates XYZ in another language. (Here XYZ stands for a specific section name mentioned below, such as "Acknowledgements", "Dedications", "Endorsements", or "History".) To "Preserve the Title" of such a section when you modify the Document means that it remains a section "Entitled XYZ" according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that this License applies to the Document. These Warranty Disclaimers are considered to be included by reference in this License, but only as regards disclaiming warranties: any other implication that these Warranty Disclaimers may have is void and has no effect on the meaning of this License.

2. VERBATIM COPYING

You may copy and distribute the Document in any medium, either commercially or noncommercially, provided that this License, the copyright notices, and the license notice saying this License applies to the Document are reproduced in all copies, and that you add no other conditions whatsoever to those of this License. You may not use technical measures to obstruct or control the reading or further copying of the copies you make or distribute. However, you may accept compensation in exchange for copies. If you distribute a large enough number of copies you must also follow the conditions in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.

3. COPYING IN QUANTITY

If you publish printed copies (or copies in media that commonly have printed covers) of the Document, numbering more than 100, and the Document's license notice requires Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you as the publisher of these copies. The front cover must present the full title with all words of the title equally prominent and visible. You may add other material on the covers in addition. Copying with changes limited to the covers, as long as they preserve the title of the Document and satisfy these conditions, can be treated as verbatim copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should put the first ones listed (as many as fit reasonably) on the actual cover, and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either include a machine-readable Transparent copy along with each Opaque copy, or state in or with each Opaque copy a computer-network location from which the general network-using public has access to download using public-standard network protocols a complete Transparent copy of the Document, free of added material. If you use the latter option, you must take reasonably prudent steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will remain thus accessible at the stated location until at least one year after the last time you distribute an Opaque copy (directly or through your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing any large number of copies, to give them a chance to provide you with an updated version of the Document.

4. MODIFICATIONS

You may copy and distribute a Modified Version of the Document under the conditions of sections 2 and 3 above, provided that you release the Modified Version under precisely this License, with the Modified Version filling the role of the Document, thus licensing distribution and modification of the Modified Version to whoever possesses a copy of it. In addition, you must do these things in the Modified Version:

  • A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and from those of previous versions (which should, if there were any, be listed in the History section of the Document). You may use the same title as a previous version if the original publisher of that version gives permission.
  • B. List on the Title Page, as authors, one or more persons or entities responsible for authorship of the modifications in the Modified Version, together with at least five of the principal authors of the Document (all of its principal authors, if it has fewer than five), unless they release you from this requirement.
  • C. State on the Title page the name of the publisher of the Modified Version, as the publisher.
  • D. Preserve all the copyright notices of the Document.
  • E. Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.
  • F. Include, immediately after the copyright notices, a license notice giving the public permission to use the Modified Version under the terms of this License, in the form shown in the Addendum below.
  • G. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given in the Document's license notice.
  • H. Include an unaltered copy of this License.
  • I. Preserve the section Entitled "History", Preserve its Title, and add to it an item stating at least the title, year, new authors, and publisher of the Modified Version as given on the Title Page. If there is no section Entitled "History" in the Document, create one stating the title, year, authors, and publisher of the Document as given on its Title Page, then add an item describing the Modified Version as stated in the previous sentence.
  • J. Preserve the network location, if any, given in the Document for public access to a Transparent copy of the Document, and likewise the network locations given in the Document for previous versions it was based on. These may be placed in the "History" section. You may omit a network location for a work that was published at least four years before the Document itself, or if the original publisher of the version it refers to gives permission.
  • K. For any section Entitled "Acknowledgements" or "Dedications", Preserve the Title of the section, and preserve in the section all the substance and tone of each of the contributor acknowledgements and/or dedications given therein.
  • L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles. Section numbers or the equivalent are not considered part of the section titles.
  • M. Delete any section Entitled "Endorsements". Such a section may not be included in the Modified Version.
  • N. Do not retitle any existing section to be Entitled "Endorsements" or to conflict in title with any Invariant Section.
  • O. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary Sections and contain no material copied from the Document, you may at your option designate some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the Modified Version's license notice. These titles must be distinct from any other section titles.

You may add a section Entitled "Endorsements", provided it contains nothing but endorsements of your Modified Version by various parties--for example, statements of peer review or that the text has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as a Back-Cover Text, to the end of the list of Cover Texts in the Modified Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements made by) any one entity. If the Document already includes a cover text for the same cover, previously added by you or by arrangement made by the same entity you are acting on behalf of, you may not add another; but you may replace the old one, on explicit permission from the previous publisher that added the old one.

The author(s) and publisher(s) of the Document do not by this License give permission to use their names for publicity for or to assert or imply endorsement of any Modified Version.

5. COMBINING DOCUMENTS

You may combine the Document with other documents released under this License, under the terms defined in section 4 above for modified versions, provided that you include in the combination all of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant Sections of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections may be replaced with a single copy. If there are multiple Invariant Sections with the same name but different contents, make the title of each such section unique by adding at the end of it, in parentheses, the name of the original author or publisher of that section if known, or else a unique number. Make the same adjustment to the section titles in the list of Invariant Sections in the license notice of the combined work.

In the combination, you must combine any sections Entitled "History" in the various original documents, forming one section Entitled "History"; likewise combine any sections Entitled "Acknowledgements", and any sections Entitled "Dedications". You must delete all sections Entitled "Endorsements."

6. COLLECTIONS OF DOCUMENTS

You may make a collection consisting of the Document and other documents released under this License, and replace the individual copies of this License in the various documents with a single copy that is included in the collection, provided that you follow the rules of this License for verbatim copying of each of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under this License, provided you insert a copy of this License into the extracted document, and follow this License in all other respects regarding verbatim copying of that document.

7. AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and independent documents or works, in or on a volume of a storage or distribution medium, is called an "aggregate" if the copyright resulting from the compilation is not used to limit the legal rights of the compilation's users beyond what the individual works permit. When the Document is included in an aggregate, this License does not apply to the other works in the aggregate which are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the Document is less than one half of the entire aggregate, the Document's Cover Texts may be placed on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if the Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole aggregate.

8. TRANSLATION

Translation is considered a kind of modification, so you may distribute translations of the Document under the terms of section 4. Replacing Invariant Sections with translations requires special permission from their copyright holders, but you may include translations of some or all Invariant Sections in addition to the original versions of these Invariant Sections. You may include a translation of this License, and all the license notices in the Document, and any Warranty Disclaimers, provided that you also include the original English version of this License and the original versions of those notices and disclaimers. In case of a disagreement between the translation and the original version of this License or a notice or disclaimer, the original version will prevail.

If a section in the Document is Entitled "Acknowledgements", "Dedications", or "History", the requirement (section 4) to Preserve its Title (section 1) will typically require changing the actual title.

9. TERMINATION

You may not copy, modify, sublicense, or distribute the Document except as expressly provided for under this License. Any other attempt to copy, modify, sublicense or distribute the Document is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

10. FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that a particular numbered version of this License "or any later version" applies to it, you have the option of following the terms and conditions either of that specified version or of any later version that has been published (not as a draft) by the Free Software Foundation. If the Document does not specify a version number of this License, you may choose any version ever published (not as a draft) by the Free Software Foundation.

How to use this License for your documents

To use this License in a document you have written, include a copy of the License in the document and put the following copyright and license notices just after the title page:

Copyright (c)  YEAR  YOUR NAME.
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.2
or any later version published by the Free Software Foundation;
with no Invariant Sections, no Front-Cover Texts, and no Back-Cover
Texts.  A copy of the license is included in the section entitled "GNU
Free Documentation License".

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the "with...Texts." line with this:

with the Invariant Sections being LIST THEIR TITLES, with the
Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.

If you have Invariant Sections without Cover Texts, or some other combination of the three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these examples in parallel under your choice of free software license, such as the GNU General Public License, to permit their use in free software.